Delayed order routing

Incident Report for Pipe17 Inc.

Resolved

The issue is resolved now. The route queue is back to normal. There is no delay observed.
Posted Aug 05, 2025 - 18:42 UTC

Update

Continuing to monitor the system as the queue is getting back down to the normal size.
Posted Aug 05, 2025 - 18:41 UTC

Monitoring

Order routing engine slowdown caused delay in routing orders for some organizations. The issue started around 9:00AM PST and internal teams were alerted around 10:00AM PST. Investigation followed, a fix was deployed around 10:30AM PST. Order routing has resumed and the backlog will be cleared in the next hour. Situation is being actively monitored to ensure all orders in the queue are processed in a short period of time.
Posted Aug 05, 2025 - 18:34 UTC
This incident affected: API (v3).